Problem with power supply connection on Pitchfactor, Timefactor, and Modfactor

Home Forums Products Stompboxes Problem with power supply connection on Pitchfactor, Timefactor, and Modfactor

  • This topic is empty.
Viewing 1 reply thread
  • Author
    Posts
    • #112176
      fkalich
      Member

      I purchased those three at about the same time, about 4 years ago.  After awhile I found that if I jarred the plug or cord on the power supply of the Pitchfactor it would turn off and come back on again.  I did not worry to much as that was infrequent and I could just avoid jarring it.   But over time it it got worse.  Then the same thing thing started happening to my Modfactor and Timefactor.  Any combination of the three pedals or three adapters, it does not matter, the same thing happens.  It sometimes now does this when I don't even think I jarrred anything.  It is very obvious to me, I will say with ABSOLUTE certainty that at the time of my purchase there was an issue with parts here in production, as all three have the same issue.  I just ordered a 2.5mm power cable extension to test out if the problem is with the plugs on the adapter of the female sockets on the pedals.  I know the problem is there, I can wiggle the plugs in any of them just a bit and and the pedal will go off and come back on.   Out of warranty of course.   If it is the socket it looks hard to get into these pedals and look at it.  I assume repair cost would be prohibitively expensive.  Even though the items were clearly defective when I bought them, the problem only slowly got this bad and they are now out of warranty now by a long shot.  Anyone seen this issue, and who knows of anything that can help me?

    • #127204
      guitardojo
      Participant

      I had the same issue with my PF. Emailed support and it was out of warranty. I was told I had to send it in and the cost would be $100 if there wasn't any other issues besides the jack.

Viewing 1 reply thread
  • You must be logged in to reply to this topic.