Problem with Space and Voodoo Lab Ground Control: toggle/active/bypass cc messages not working right

Home Forums Products Stompboxes Problem with Space and Voodoo Lab Ground Control: toggle/active/bypass cc messages not working right

  • This topic is empty.
Viewing 0 reply threads
  • Author
    • #111066


      I've been using a Voodoo Lab Ground Control Pro with the Space to make program (preset) changes so far, but now I want to use the Ground Control to also send CC messages to be able to hit the hotswitch and the active switch remotely. I configured the RCV CTL on the Space to receive the hotswitch signal and everything works fine in that regard.

      The problem comes when I assign the active switch. I read in the manual that I can  choose between 3 parameters for that: BYPASS, ACTIVE and TOGGLE. As I read in the manual, the toggle parameter allows to toggle between active and bypass so I imagined that would be the one I should be using. I assigned that one and tried it: it works but it requires that I hit the switch twice each time to turn the unit on or off.

      I tried assigning BYPASS and I was surprised to find it works the way the TOGGLE parameter was supposed to work because it activates and deactivates the unit too. Then tried ACTIVE and found that it works exactly the same as BYPASS (what's the point on having 3 parameters that do the same?)

      Anyway, I could use BYPASS or ACTIVE as a toggle and problem solved, right? More weird stuff! If i hit one of those right after a program change, the space seems to ignore the first hit and do absolutely nothing, but if I hit the ground control again, it begins activating and deactivating correctly, and it works perfectly until I make another program change and the story begins again:ignores the first message to toggle, and then works fine ever after.

      In a nutshell:

      CC hotswitch: working perfectly

      CC TOGGLE: works but I need to press the switch two times to activate/deactivate

      CC BYPASS-ACTIVE: they work like a toggle, with a single press of the switch, but if i hit any of them after a program change, the space does nothing on the first press, then begins working perfectly with the following ones.

      Also, I have just discovered that the program change problem I just described only happens when I change to certain presets. With others seems to work fine.

      I have checked and rechecked the midi configuration and seems to be OK, and as I said, the hotswitch message does work.

      Could anybody help me with this? I've been out of my mind all evening! Sad

Viewing 0 reply threads
  • You must be logged in to reply to this topic.