Saving in H90 Control

Home Forums Products Stompboxes Saving in H90 Control

Viewing 11 reply threads
  • Author
    • #172144

      I am having a problem saving in the H90 Control App, or I don’t understand how the save function works.

      1) I have a list called “My List”.

      2) I copy a program from a user list and paste it into an empty INIT in My List.

      3) The program name has an asterisk notifying me that it needs to be saved.

      4) I click the save button, but the asterisk does not disappear.

      5) I have to click on another INIT program slot, which makes the asterisk disappear.

      The same thing happens when I try to edit parameters in the program.

      1) If I change the mix value, for example, and then click save, the asterisk stays and the value of mix reverts back to the old value.

      2) If I click on an INIT  slot and then switch back to my program, the asterisk disappears and the value I changed has been saved.

      Even weirder things happen when I create a new program from presets

      1) Choose a reverb preset for B and a Chorus preset for A

      2) Rename the program

      3) Asterisk appears letting me know I have to save the program.

      4) Click save and the name of a program I copied to the clipboard appears in the INIT slot.

      5) If I click on another INIT slot and then back, the program I just created with the correct name appears in the slot.

      Any idea what I am doing wrong or what the problem is?

      I don’t have any of these issues when I try all of this on the pedal itself.

      Any help would be appreciated.

      Show More...
      Show Less...
    • #172145

      3) The program name has an asterisk notifying me that it needs to be saved.

      Are you using any kind of external controllers like MIDI, aux, expression, etc?

      There shouldn’t be an asterisk after you paste the program to its new location.
      Maybe your H90 is receiving some kind of external control data that changes something in your program, and that’s why you’re seeing the asterisk?

    • #172146

      Hi, Thanks for the reply. While I do have a controller, it is not receiving any external control data. I removed the controller, and had the H90 connected to the computer via USB.

      I did find one thing. Does not matter whether I paste the program or load it from the program list, the asterisk appears. However, if I use the save icon at the bottom of the list window the save function works as it should. If I use the save button in the upper right hand corner, then the odd behavior appears.

      Nevertheless, if I edit a parameter, and use either the save button at the bottom of the list window or the save button in the upper right hand corner, the behavior I mentioned above persists.

      Finally, I am connecting the H90 to an Intel Mac mini. I thought I would connect it to my M2 Max Mac Studio to see if the same behavior persists. I can’t get H90 Control app to recognize the H90, its connect button is grayed out. However, I know the computer see the H90 because if I go into system reports and check the USB connected devices, the H90 appears.



    • #172147

      I’m on Windows, so maybe it’s different on Mac?….I’m not sure.
      Or maybe your computer is sending the H90 some kind of MIDI data over USB?

      I’ll try it here on my end (with both Save buttons) and see if I can reproduce the issue.

      BTW, have you tried a different USB cable, just in case?

    • #172148

      Tested it here on my computer, everything works as expected.

      I screen captured it, maybe it’ll help you figure it out:

      H90 Control – save test

    • #172149

      Thanks for the clip. That is exactly how I expected the save function in the app to work. Unfortunately, on both the Intel Mac mini and the M2 Mac Studio, it is not working as it should. As you said, you are on Windows, so maybe Mac OS has a problem.

    • #172150

      OK, curiouser and curiouser. When I follow the steps outlined in your clip, it now works as it should.

      However, if I click on an INIT program in my list, then click the program tab at the top, then load a program, I still get the asterisk and the save button still functions the way I described it in my first post.

    • #172151

      Ha, interesting.

      Just checked and it’s the same here, when I choose a program from my list under the Programs tab (and not the left column), the program shows the asterisk.

      Maybe it’s because this program is now coming from the main programs “pool” and not yet saved in the specific loaded list?

    • #172153

      That is what I think. But what is puzzling is clicking the save button in the upper right hand corner does not remove the asterisk. I actually have to click on another program in the list to remove the asterisk.

    • #172160

      Although I thought i posted this, it does not appear in the thread. I did get the H90 to connect with the M2 Mac Studio by deleting the pedal in the app window and adding it again. Now the app connects flawlessly to the H90.

    • #173062

      cscotto, I was experiencing exactly the same weirdness. I have an M2 Macbook Air, with the additional strangeness that when I click on either ‘Save’ location another program is then listed in the user slot I just saved to, and displays an asterisk.

      I was using the USB-C connector at the H90 unit, and connected that to a longer USB 3.0 Type A (blue color) extension cable, using adapters. When I removed the USB cable extension and just used a single cable from H90 to my Mac, that cleared up all the weirdness.

      Try changing the cable you use, and hopefully that will solve the problem.

    • #173221

      Thanks for the reply. I experienced exactly the same thing. I have the H90 connected to a hub in my rack using a USB-C to A cable, then i connect the hub to computer with an extension cable, so yes it could be the cable. I will try a USB-C to C cable and if that works when I get some time. The rack is kind of cramped, so switching cables is not a simple task. I will report back.

Viewing 11 reply threads
  • You must be logged in to reply to this topic.