TF Volume drop

Home Forums Products Stompboxes TF Volume drop

  • This topic is empty.
Viewing 8 reply threads
  • Author
    • #106541

      I spent some good time with my rig the other day and I was making patches on my Musicomlab efx II and I noticed that when I enabled my TF's loop that there was a very noticeable volume drop. 

      This happened when the TF was active and in bypass mode…

      Has anyone had this happen to them?

      *i have not yet updated my TF, so i cant say if that will or will not fix my problem*

      Any suggestions, please help!



    • #119268

      level switches ok?

    • #119270
      Eventide Staff

      What bypass mode are you using ?

      If you are using the default setting (RELAY), the TF is in effect out of circuit during (true) bypass, so the problem would be elsewhere.

      If you are using another mode, Mr. Caveman's suggestion will be of service.

    • #119272

      I have the same problem.

      I have the TF in the amp effects loop and on this particular pre-amp there is no way to adjust the volume of the loop. When I switch the loop in with just the TF in the signal path there is a volume drop. This is with both switches in the 'line' position, which is correct for this set-up. (no combination of switch positions gives unity gain)

      It seems like a basic design floor in these pedals. All that is needed is an output level control. Other rack based units that I own have this as standard. It's a real shame as the effects are fantastic. I was going to buy a PF as well, but instead I'm going to return my TF and MF as they are just unusable in a loop setup like this.

      Eventide, please put an output volume control on these pedals! (physical knob / menu setting, whichever…just someway to control the output lvl)

    • #119275

      forgive me because i am stupid, but by level switches do you mean the flip switches on the TF, if so they are set on amp and guitar… still having this problem with the new update… 

      help me


    • #119276

      Ok so I changed the bypass mode to relay like you said

      And when it is in bypass now there is NO VOLUME DROP, so this is good..

      however when the TF is active there still in a big volume drop..

      Any suggestions?



    • #130406

      Try both switches down.. line level.

    • #130468

      I tried both switches down, and i still have the problem

      the problem being when the TF is ACTIVE there is a volume drop.. 

      Could this has something to do with my chain of effects??

      Any other suggestions?

      As of now I have taken it off my board because of this volume drop, I dont want to have to sell it, its too cool!

    • #130470

      Are You using the Killdry feature?

Viewing 8 reply threads
  • You must be logged in to reply to this topic.