Time Factor Midi problem…help

Home Forums Products Stompboxes Time Factor Midi problem…help

  • This topic is empty.
Viewing 9 reply threads
  • Author
    Posts
    • #114463
      riksplace
      Member

      Just now setting up my RJM Mastermind PBC to control my Time Factor with midi. The PBC is making changes to my Source Audio Programable EQ just as it should….so problem is not the PBC. Midi cable is good. As I said the settings on the PBC are fine. But nothing happens when it should on the Time Factor.

      It’s updated through the H9 Editor with the latest update. When I press PRESET 1 on my PBC it should change my Time Factor to a predetermined preset. It just doesn’t move no matter what I do to it.

      Midi recieve channel is “1” as it’s set on PBC. Offset is set to “0” on PBC as the Time Factor midi Program Changes start at “0” (instead of “1” as on many devices).

      What can I be over looking here?

    • #147656
      gkellum
      Participant

      Have you tried switching the MIDI receive channel to OMNI to allow it to be controlled on all channels?  With this MIDI stuff, you have to be aware that off my one errors come up pretty frequently as some manufacturers number things starting from 0 and others number things starting at 1.

      Also, you have the the Mastermind connected directly to the TimeFactor?  Even if that's not what you want long term, you'll want to do that while figuring this problem out.

      If I were you, I might try resetting the TimeFactor's system settings to make sure there aren't any weird settings that are screwing something up.  You do that by starting it up with the right footswitch and the algorithm selector knob pressed.  You'll need to re-adjust your MIDI settings of course after doing this, but it won't affect your presets.

       

    • #147657
      riksplace
      Member

      Thank you. Yes…it’s connected directly to the PBC. I will try the “omni” setting….and it’s actually all I’m trying to control with the midi. I just tried the SA Prog EQ to be certain the PBC was sending midi messages and the midi cable was good.

    • #147658
      riksplace
      Member

      OMNI didn’t work. I’ll try resetting the System Settings

    • #147661
      riksplace
      Member

      Reset System Settings…..no go. Tried Midi Rec on OMNI and 1 and 2….no go. Not certain what some of those midi controls do in the System menu but they are now on the factory default (except the REC ch is on OMNI now).

      I bought the TF used but it is in pristine shape with all the orignal materials and box and of course it’s registered to me now. Everything rest to factory and updated to latest versions. Don’t know what esle to do. Pedal works great except for midi control. I’ll keep chuckin’ at it. 

    • #147687
      riksplace
      Member

      OK….I’m totally at a loss now. Got the 2nd Time Factor in today and the Mastermind PBC makes no midi changes to it. I can control other midi pedals with the PBC….but NOTHING happens with the Time Factor. I’ve tried everything I know. No way both Time Factors are defective. I’ve tried different midi channels. Tried “omni” receive on the TF. Tried different midi cables. Works easily and fine on other midi pedals. I installed a 3rd midi pedal in about 60 seconds and it worked perfectly the first time. So I know PBC sends midi commands. I know my cables are good. I uninstalled the TF from the PBC and re-installed it. PBC and TF have latest software and updates.



      I’m just stumped (not to mention I just spent $275 on a 2nd used TF).



      Any ideas at all?

    • #147688
      nickrose
      Moderator
      Eventide Staff

      What actually are you trying to control on your TF, and what settings do you have on your pedalboard to do this ?

      Have you tried different MIDI cables ?

       

    • #147690
      riksplace
      Member

      Tried different midi cables. I have several. They all worked with the other midi pedal.

      I have several presets set on the Mastermind PBC. When I go to different presets I just need it to tell the TF to cahnge to the proper delay preset. Very simple. Not trying to get it to do anything complicated at all.

      Just nothing happens at all on the TF when I change presets on the PBC. The other midi pedal will change. I have now taken the other midi pedal out of the picture so the TF is connected directly to the PBC. All on midi channel 1 (although I have tried other midi channels just in case it would be something simple like that not working). Been over everything on the TF and just can’t figure out why it won’t accept the Pgrogram Change command from the the PBC.

    • #147691
      gkellum
      Participant

      Do you think you could hook up your RJM Mastermind PBC to computer and check what MIDI messages it's sending out and let us know?  My best bet at the moment is that maybe it's send out a program change together with possibly other MIDI messages that for some reason or other might be confusing the TimeFactor.  For instance we had a problem with the H9 where certain controllers were sending out a bank select in certain situations and that was being mishandled by the H9 as a MIDI CC.  If you could let us know what it's sending out, we could reproduce your set-up in our office.  On Windows MIDI Ox is a reasonably good MIDI monitoring app, and on Mac MIDI Monitor is pretty good.

      • #147692
        riksplace
        Member
        gkellum wrote:

        Do you think you could hook up your RJM Mastermind PBC to computer and check what MIDI messages it’s sending out and let us know?  My best bet at the moment is that maybe it’s send out a program change together with possibly other MIDI messages that for some reason or other might be confusing the TimeFactor.  For instance we had a problem with the H9 where certain controllers were sending out a bank select in certain situations and that was being mishandled by the H9 as a MIDI CC.  If you could let us know what it’s sending out, we could reproduce your set-up in our office.  On Windows MIDI Ox is a reasonably good MIDI monitoring app, and on Mac MIDI Monitor is pretty good.

        I’ll have to figure out how to do that with MIDI Ox (Windows here). But probably a good thing to learn. I feel I’m reasonably adapt at midi things. In the past I had a complete rack set up with 3 drawers of pedals run into 2 switchers that were all controlled by a Mastermind GT-22 floor control. And I can get other midi pedals to wrk with this PBC controller. Just not the TF.  The PBC loads default set up for the TF when installed and the only thing I had to change was the PC offset (although I’ve tried that on default setting and it doesn’t make a difference either). Tried “OMNI” recieve on the TF. Tried several different channels on the TF. Just a head scratcher. PBC is set to “no banks”…..I’ve tried several things in a very controlled order (so as not to get several things messed up at once). I’ll figure out how to monitor the PBC midi output and try to send it to you when I can. Any other ideas? Strange 2 different TF’s do the same thing.

         

      • #147694
        riksplace
        Member
        riksplace wrote:

        gkellum wrote:

        Do you think you could hook up your RJM Mastermind PBC to computer and check what MIDI messages it’s sending out and let us know?  My best bet at the moment is that maybe it’s send out a program change together with possibly other MIDI messages that for some reason or other might be confusing the TimeFactor.  For instance we had a problem with the H9 where certain controllers were sending out a bank select in certain situations and that was being mishandled by the H9 as a MIDI CC.  If you could let us know what it’s sending out, we could reproduce your set-up in our office.  On Windows MIDI Ox is a reasonably good MIDI monitoring app, and on Mac MIDI Monitor is pretty good.

        I’ll have to figure out how to do that with MIDI Ox (Windows here). But probably a good thing to learn. I feel I’m reasonably adapt at midi things. In the past I had a complete rack set up with 3 drawers of pedals run into 2 switchers that were all controlled by a Mastermind GT-22 floor control. And I can get other midi pedals to wrk with this PBC controller. Just not the TF.  The PBC loads default set up for the TF when installed and the only thing I had to change was the PC offset (although I’ve tried that on default setting and it doesn’t make a difference either). Tried “OMNI” recieve on the TF. Tried several different channels on the TF. Just a head scratcher. PBC is set to “no banks”…..I’ve tried several things in a very controlled order (so as not to get several things messed up at once). I’ll figure out how to monitor the PBC midi output and try to send it to you when I can. Any other ideas? Strange 2 different TF’s do the same thing.

         

        Show More...

        well…..someone on another forum figured it out. I can’t have the Time Factor connected to the USB when in use. I simply unplugged the USB cable and the midi commands worked just fine.

        Kind of wierd you can’t leave the pedal hooked via USB to the editor while in use….but I guess I can live with that.

        Show Less...
    • #147697
      gkellum
      Participant

      Wow, I'm sorry that that possible problem slipped my mind.

Viewing 9 reply threads
  • You must be logged in to reply to this topic.