Timefactor Looper Bug (since v5)

Home Forums Products Stompboxes Timefactor Looper Bug (since v5)

  • This topic is empty.
Viewing 3 reply threads
  • Author
    Posts
    • #112986
      xdadex
      Member

      Hey guys,

      I’ve been having this issue for a while now and had hopes that it would be fixed in this new build that come out today (v5.2)… But alas, it’s still doing it.

      The way i’m using the pedal might be a little esoteric, so it’s possible you’re not aware of the issue. Let me try to explain.

      I am controling the Timefactor pedal via MIDI in Ableton Live (Patch changes and CC codes in the timeline).  *see pic below

      I created an empty loop preset and use clips in the timeline to control the record, play, & stop functions || Red clip = Rec (CC 20), Green = Play (CC21), Grey = Stop (CC22) || (i’ve also unassigned these CC codes from their other parameter control functions). aka, I can loop and chance patches without touching a thing.

      I got everything working pretty smooth and consitent (messing with the length of the clips in the timeline helped)

      … until I update the firmware from v3.5 to the v5.0+ versions where I could use H9 control.

      Problem: only happens about 1/10 times.  When the playhead passes over a red record clip in the timeline (which should begin recording), it records and then plays a millisecond of audio that creats a loud horrible buzzing sound that gets louder and louder until I change the patch.

      The only way I have found to fix this bug is to revert back to v3.5. (which sucks because I cant use the H9 control anymore).

      Show More...

      Like I said, pretty unusual setup / problem to be having. wondering is anyone has experienced anything similar? or what might be causing the problem?

      thanks.

       

      Show Less...
    • #141440
      wedelich
      Moderator
      Eventide Staff

      Hi xdadex,

       

      Have you made any progress since posting this?  We'll have to try and duplicate this on our end.  Would you be able to boil it down to the simplest Live session you can create that demonstrates the problem and send us that session?  If not, perhaps you could at least detail the steps to set up a simple session and steps to reproduce the bug? 

      A few more questions:  Are you using the Looper in Tempo Mode?  Are you using MIDICLK?  What's the length of the MIDI CC signal you're sending for REC, PLAY, and STOP?  I ask that last one b/c it's probably best if they are as short as possible.  

       

      • #142769
        xdadex
        Member
        wedelich wrote:

        Hi xdadex,

         

        Have you made any progress since posting this?  We’ll have to try and duplicate this on our end.  Would you be able to boil it down to the simplest Live session you can create that demonstrates the problem and send us that session?  If not, perhaps you could at least detail the steps to set up a simple session and steps to reproduce the bug? 

        A few more questions:  Are you using the Looper in Tempo Mode?  Are you using MIDICLK?  What’s the length of the MIDI CC signal you’re sending for REC, PLAY, and STOP?  I ask that last one b/c it’s probably best if they are as short as possible.  

         

        Sorry for the delayed response. I’m experiencing some issues again and doing some more troubleshooting today. I’ll try to send you some of my results and adress your last post tomorrow. hopfully, I can hepl get to the bottom of it. I’ve tried various other loopers that have MIDI and theyre even more unreliable.

         

        Show More...
        Show Less...
    • #142770
      xdadex
      Member

      In my case, I’m using preset # 19 as my looper. with CC 20, 21, and 23 = REC, PLAY and STOP.  I go in and unassign any other CCs in the pedal so theres no confusion. I have CLKIN turned on and have the pedal accepting MIDI IN on channel 8.

      First I make a clip that switches to preset 19: In the clip settings on the bottom left, I type “19” into the “pgm” box.

      Then a make another clip that will start recording: bottom left, hit “envelope” to expand the box and under midi cc go to 20. I make the value of this clip between 64 – 127 so it will activate the CC. (im not 100% I need to do this, but it makes sense) [see attached pic]

      Then I do this same thing with PLAY and STOP.

      Thow a beat under it so you can hear if its in sync.

      That should be it. This works relatively well with the older firmware (occasional slightly out of sync). the update just screws up ALL the time. and the same thing with the H9 looper.

      .

    • #142772
      wedelich
      Moderator
      Eventide Staff

      It occurs to me that we added MIDI START and STOP to the V5 Looper.  The Looper will always respond to these commands (details as to how are in the Looper manual in the info tab in H9 Control).  It's possible that Ableton is sending START and STOP when you play your loops (a lot of DAWs do this by default) and there might be contention b/t these and your CC values that you manually programmed to do the same.   Maybe try a simple setup without sending any of your CC's for START, REC, and STOP and see if the Looper responds.  Alternatively there may be a setting in Ableton that allows you to turn these START and STOP commands on or off? 

       

Viewing 3 reply threads
  • You must be logged in to reply to this topic.