Timefactor Problem. Single bar on the dot matrix, moves a bit to the right and dies.

Home Forums Products Stompboxes Timefactor Problem. Single bar on the dot matrix, moves a bit to the right and dies.

  • This topic is empty.
Viewing 4 reply threads
  • Author
    Posts
    • #112350
      ricardogrilli
      Member

      Hey folks!

      So i got this problem on a timefactor. Turn it on and I get a single bar on the dot matrix, it moves and
      and the whole thing dies.
      Using an original power source, only used the pedal at home and it worked before.

      Any ideas?

      Greatly appreciated all!

      Best,

      Ricardo

    • #127544
      nickrose
      Moderator
      Eventide Staff

      Sorry – you have a problem. Contact support@eventide.com. Tell them if you have recently updated it or changed anything else.

    • #127679
      Otto Schulz
      Participant

      I have the same  problem . 

      Im from argentina . 

      That I can do, buy it at guitar center a month ago, and only use it twice

      Gracia s

    • #138702
      nickrose
      Moderator
      Eventide Staff

      I would suggest you take it back to the store – it may well have a problem that needs it to be returned to the US.

    • #138703
      ricardogrilli
      Member

      Hey Otto,

      Sorry to hear it, run to guitar center and send it back to the US because if your warranty runs out you have to pay for the repairs yourself. People at eventide are great but doesn't change the fact I have to pay to fix something i didn't break.

      best

Viewing 4 reply threads
  • You must be logged in to reply to this topic.