TimeFactor Software Update Not Working

Home Forums Products Stompboxes TimeFactor Software Update Not Working

  • This topic is empty.
Viewing 1 reply thread
  • Author
    Posts
    • #115142
      spydog
      Member

      I first tried to update the software on my TimeFactor about 7 years ago, but sadly, I was one of the “lucky” few that had a mysterious issue where my PC had trouble properly recognizing the TimeFactor.  Since then, each time I’ve bought a new PC or laptop, I have tried to do the update again, but have had the same exact issue.  I’m hoping that, after all this time, perhaps a fix has been discovered.  If anyone can help, I would be very grateful.

      The issue:  My computers “see” the TimeFactor, but in the Device Manager, it always shows up with a yellow exclamation point and error code 10.  So, when I run the Eventide Software Updater, it thinks that there are no Eventide devices connected to the computer.  I have made sure that the midi clock is set to “off.”  I have tried mutliple USB ports and mutliple USB cables.  There are no other USB devices connected to my current computer (except for mouse/keyboard).  I have  been through this, with the same exact results on approximately 5 different PCs/laptops over the years.  I have drawn the conclusion that there is a problem with my TimeFactor as it is the only device that has been in common with all the iterations I have tried.    

      I just want to get the upgraded sounds and functionality for my TimeFactor.  I have lived with the original software for all these years, but it really bugs me that I can’t get the upgrade.  Again, any help would be greatly appreciated.

       

    • #150933
      nickrose
      Moderator
      Eventide Staff

      Alas, it sounds as if it has some USB problem. Given that you have the same issue on multiple computers, it is probably not an installation issue.

      The only thing I can suggest is that you send it for service. Probably the USB chip needs replacing. support@eventide.com

       

Viewing 1 reply thread
  • You must be logged in to reply to this topic.