- Eventide Audio

Reply To: PLEASE help me update Eclipse from v1.101 to version 4 – cards do not work. Also Eclipse question

Home Forums Products Rackmount PLEASE help me update Eclipse from v1.101 to version 4 – cards do not work. Also Eclipse question Reply To: PLEASE help me update Eclipse from v1.101 to version 4 – cards do not work. Also Eclipse question

#158571
nickrose
Moderator
Eventide Staff

If all else fails, either return to sender, or put it in for service (support@eventide.com).