Brand new unit – something’s rattling

Home Forums Products Rackmount Brand new unit – something’s rattling

  • This topic has 3 replies, 2 voices, and was last updated 5 months, 2 weeks ago by tbskoglund
    Eventide Staff
    .
Viewing 3 reply threads
  • Author
    Posts
    • #164965
      EQss
      Participant

      Hi Everyone.

       

      first post. Just taken delivery of my H9000R. I’ve unboxed it – but not installed or set it up yet. There seems to a small object (possibly a screw) loose inside and it slides about when ai tilt the unit. Should I simply reject it and return or open up one of the expansion slots and see what falls out before I power up? Purchased from a very reputable European dealer with good customer service and warranty cover. But wondering what opinions might be. Unfortunately have have no other in stock so I’m looking at a refund or a long delay for a replacement.

      thanks for any advice.

    • #164966
      tbskoglund
      Moderator
      Eventide Staff

      Hello,

      Sorry for this inconvenience! I’ve received your support ticket and will reply to you there. Thanks!

    • #165008
      EQss
      Participant

      @Support – Thanks for the feedback. And the earlier fast response. I’ve updated the ticket with photos. There was a very small plastic crew (clear) loose under the main motherboard. Any chance you can advise is safe to power her up and test over the weekend? Thanks.

    • #165009
      tbskoglund
      Moderator
      Eventide Staff

      Theres a bit of a delay from when we respond to the support ticket and when the email gets sent to you, but I just responded to your ticket a few moments ago and will continue to help troubleshoot the issue there. Thanks.

Viewing 3 reply threads
  • You must be logged in to reply to this topic.