Eclipse – upgrade

Home Forums Products Rackmount Eclipse – upgrade

  • This topic has 2 replies, 1 voice, and was last updated 4 months ago by Fender17.
Viewing 2 reply threads
  • Author
    Posts
    • #162469
      Fender17
      Participant

      I have a problem to upgrade Eclipse. It has system v. 2.50 and bootloader v. 1.11.

      I used 1 GB Sandisk CF card (do not know if this is not cause of problems) formated in Eclipse. Used two different cards.

      When trying to load new system (v. 3.51) “Loading Romprog.exe from card” appears on display. But nothing is happening and after some time the display either becomes corrupted or the  “Loading Romprog.exe from card” becomes black on white. In both cases nothing happens for many minutes and the Busy LED does not blink to indicate content is read.

      The instructions how to upgrade system says that there may be problem with bootloader v. 1.10 that leads to display corruption and inability to update system. But I have v. 1.11.

      I could try to reflash bootloader, but I am a bit scared as I do not know if CF card is the problem or old/buggy bootloader is the problem. Or something else… I know that flashing bootloader is always potencially dangerous thing, so I prefer avoid it if not necessary…

    • #162470
      Fender17
      Participant

      One more thing. Eclipse works OK after unsuccessfull attempts to upgrade system.

    • #162477
      Fender17
      Participant

      Well, I succeeded, at last. System is 4.01 and also bootloader has been updated to 1.25.

      It seems that formatting to FAT on PC did help. In trials before I let Eclipse to format the card, so it should have been formated correctly… But maybe was not. The formatting seemed to take very short time in Eclipse, so maybe it was not done because of some reason and card stayed FAT32 or whatever it was formated to years ago….

Viewing 2 reply threads
  • You must be logged in to reply to this topic.