Home Forums Products Rackmount ONE MORE BETA BUILD! V3.5B3 posted

  • This topic is empty.
Viewing 13 reply threads
  • Author
    • #105290

      Hi folks

      last night a new build for Eclipse OS 3.5 has been posted.
      V3.5B3 brings back ModBlock sources in the Modulation section.
      We advice expert users and those who have installed the previous version B2 to install this build.

      Specific areas that need testing and attention:

      make sure you hear everything correctly; no noises whatsoever. Change as many presets as you can..and also try working at 96KHz sampling rate, loading those presets that can run at such rate.

      Eclipse Externals have been doubled up to a hefty 16! Try patching as many of them, definitely MORE than 8, to system and presets parameters and check how the unit responds to MIDI CC messages. Load as many presets as you can…trying the 3 internal MIDI maps and a new map you can create.

      Use the unit as you'd do in your daily digital fx routine (!).

      Notice anything that we should know and take care of.

      After installation please execute a CLEAR SETUP! That should be asked by the unit anyway, so press the YES key.
      After reboot, do another CLEAR SETUP by power cycling the unit with the SETUP key pressed & held.

      Please let us know about anything you may find odd.

      The build is here:


    • #116837

      Hello again Italo,

      Some more modblock strangeness. This time a little hard to pin down. I don't know if this is a beta issue or something I did, but I thought I'd report it anyway.

      After installing beta3 and clearing the setup (this should return the unit to Factory fresh settings right?). I went to patch 115 St.Chorus and made some tweaks. I applied the modblock LFO to Delay 1&2. The patch worked fine.

      Now here's the strange part. I saved the patch and moved to another patch. Then upon returning to my modified ST. CHorus patch, I noticed that the Delay 1&2 parameters were not modulating whenever there was a signal present. ie. The LFO stopped working when audio was detected at the inputs. It turns out that somehow, the Modblock LFO has it's RATE parameter being modulated by Follower#1.

      So, stay with me here. The odd thing is that the original ST.Chorus does not have this modblock LFO RATE modulation, and I did not apply it myself. So where did it come from? Even wierder – when I loaded another patch (any patch infact), the SAME modulation was applied to the LFO RATE. My modblock setting is PROG, not GLOBAL, so this shouldn't happen.

      Since I've removed that RATE modulation, the modblock has behaved as it should, and I haven't been able to reproduce it, but there was definately something strange going on, with the modblock behaving globally when it should be per program.

      I hope you can follow this!

      Rozz 🙂
      Anyway, I've been unable to reproduce this bug (if it is indeed a bug and not user error), but if you notice anything odd in your modblock settings then maybe it's related.

    • #116838

       Rozzer, thanks againg for reporting things!

      Something is not clear:

      you say you have ptched Delay1 and 2 to the ModBlock LFO. Then you say"The odd thing is that the original ST.Chorus does not have this
      modblock LFO RATE modulation, and I did not apply it myself. So where
      did it come from?"

      ???? Did you create this modulation patch or not? I don't understand the second statement then.

      I'd like to have ALL settings you have mede when patching Delay 1 and 2 to LFO.

      Is this LFO#1 living in the ModBlock?

      I need to recreate the problem.


    • #127862

      Sorry Italo, some confusion there. For some reason your forum software is stripping the carriage returns from my posts!

      I DID apply Modblock LFO to the Delay 1 & 2. I DID NOT apply the Follower#1 modulation to the Modblock LFO RATE.

    • #127863

       Ok.Clear now!

      Please what are all the settings you choose in the Modulation, when patching the 2 delays to the LFO#1?


    • #127864

      Hi Italo,

      OK, here's how to reproduce the bug:
      1. Make sure Modblock is set to PROG
      2. Load up any patch
      3. Go to Modblock LFO and hold the softkey for RATE
      4. Assign Follower#1 to modulate RATE
      5. Load a different patch
      6. Go to Modblock for that patch. You will see that LFO RATE is still modulated by Follower#1.

      So, Modulating Modblock parameters ignore the PROG setting and work globally.

    • #127865


      this is completely different from what you described so far.

      Now you are saying that you have patched FOLLOWER to the MODBLOCK LFO rate.

      Before you said you patched the MODBLOCK LFO to Chorus delays 1 and 2.

      FYI info, the PROG setting means that any patch *between MODBLOCK modulators AND presets parameters* will be valid for a single program. Here you describe patching a *MODBLOCK modulator (Follower) to another MODBLOCK modulator (LFO rate)*  and this is not covered by the PROG setting in the system.

      It's obvious that if you patch a Modblock modulator to another, this will always work like that, regardless of the MODBLOCK preference (Global vs. Prog).

      No bug to me.



    • #127866

      Appologies for confusing you. I'm a little confused by this myself. I thought in my last post that I had something reproducable, but going back to the Eclipse once again, it isn't working as I described.

      There definately was some strange behaviour with modulating modblock parameters with another modblock parameter. Maybe *under certain conditions* these 'nested' modulations get tranfsered from one patch to another, when they shouldn't (and they don't most of the time!). Anyway, until I can make something 100% reproducable, I'll stop wasting your time 😉

    • #116856


      Installed 3.5B3. All indications were that the code took.

      After reboot, did not have any input signal  level indication

      on the meter led.(using analog in). 

      Output from Eclipse is nothing but noise.

      Did a reinstall of OS 3.5B3 and noticed I do not get a CLEAR SETUP

      request after intstall. I do get PROGRAMMING COMPLETED,


      As you suggested in your install notes, I did a CLEAR SETUP

      by cycling power with SETUP key pressed and held.

      When prompted I reply YES to the RETURN TO


      The Eclipse is still not working right. No input Signal level indication

      plus noisey output



    • #116858
      Eventide Staff

      Did the Eclipse work with version 3.1?

      If so did you try RELOADING 3.1 and did the problem persist? This sounds more like a problem with the specific unit than a beta software problem, but the only way to be sure is to reload the old software. After you've done that, please report your results!



    • #116865

       Hi Jim

      you didn't get a CLEAR SETUP request because the unit doesn't see the second installation of the same system as a new system.

      I would try what Richard suggests, that is reinstalling 3.1 and check if it works correctly. This will isolate the problem. 

      What serial # is the unit?


    • #127887

      Eclipse s/n: Q-013919
      Re-installed 3.1 and everything works fine
      so will probably stay at that rev. until final
      3.5 release.

    • #127903
      Eventide Staff

       We've found the problem ! It applies to units shipped after late 2005 and is fixed in V3.5B4 which is now on the Web Site.

      But, unless you need the other features, you may well want to wait until the full release. 

    • #127906

       yes! V3.5B4 works….thanks

Viewing 13 reply threads
  • You must be logged in to reply to this topic.