SP/DIF problems

Home Forums Products Rackmount SP/DIF problems

  • This topic is empty.
Viewing 5 reply threads
  • Author
    • #107210


      I am having some severe SPDIF problems with my system.

      I am using Logic Pro 9.1.1, a Focusrite Saffire LE soundcard, on my Macbook Pro 10.6.4, and my trusty Eclipse 4.01.

      I am trying to get Logic to use the SPDIF connections from the saffire -> Eclipse.
      This have been working in the past, but now after i have re-arranged my home-studio, it doesn't anymore.

      Instead of explaining what i do, i have made a small movie which shows, what
      goes on – http://anacropolis.dk/eclipse.zip – rename the file to .mov once you have downloaded it.

      In Logic i am using a plugin I/O which is a clever little gadget which on the selected track lets me insert a hardware unit in the plugin chain for that track.
      I have also tried making another track outputting to SPDIF with the same missing results.

      It doesn't do this in this video, but when clicking the SPDIF lock button, Saffire give me errors such as got sample rate 41018 and got sample rate 42018 from ext, the logic project is running 44.1Khz.
      Sometimes eclipse also just says "unlocked", instead of srcdata err.

      So something is communicating, but doesn't like what it gets.
      Also as you can hear in the video, after choosing XLR i get the noise from the eclipse back into logic, so the SPDIF must be working, and only the send having problems.

      Can someone please help me, have i forgotten something?

      Best regards,


    • #120659

      Sorry if I'm wrong or don't get the point but, if your clock master is Saffire, leave it to eg. 44.1 samplerate and set Eclipse to clock "dig-in"  (slave). EXT led should stay lit now on Eclipse? If not, try toggling sample rate 44<->48 on your Saffire panel

      ps. I also have Logic and same i/o-plugin setup with Eclipse.

    • #120660


      And thank you for your reply.

      The solution you have suggested is exactly what i am trying, which the video hopefully should be showing. And it is this that isn't working……

      I have tried with fixed khx settings and the digin… setting, and no matter what, eclipse will not lock the signal….


    • #131839
      Eventide Staff

      Thank you for your nice movie. Be aware that it is quite likely that your problem is something to do with your computer hardware or software, in which case we cannot help you.

      But, a few things we can try. Firstly, I note that your Digin Status shows an SRC error. This suggest that sample rate conversion is turned on – try turning it off and setting Digin to RCA.

      It may be that you are trying to run your computer at multiple sample rates, but this will probably not be successful.

      If that does not help, connect an RCA cable between the Eclipse digital in and out, set SRC to off, and clock to "int 48K", with digin set to "RCA". If the EXT light is flashing, try a CLEAR SETUP  (see User Manual). If this does not fix it there is a hardware problem and you should contact support@eventide.com. If it is not flashing (meaning it has locked to the input), the Eclipse is probably fine, and your problem is elsewhere.

      The fact that your DAW showed an invalid sample rate is a symptom of the problem – if the Eclipse is set to digital in sync and it is unlocked, the sample rate is undefined.

    • #131862

      Hi Nick,

      And thank you for your reply.

      I tried turning Sample rate conversion off, with no luck.

      and i tried the RCA cable in in & out also with no luck, and also cleared the unit back to factory defaults, and cleared internal memory. so i will contact support.



    • #131866
      Eventide Staff

      Do try different cables before sending it back …

Viewing 5 reply threads
  • You must be logged in to reply to this topic.